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Site User OC/RDC v5.2 Login Page 
https://onsite.medtronic.com 

Note: if you bookmark the login page, please be sure to only bookmark 
https://onsite.medtronic.com and do not include the remainder of the URL. 

 
 
This is the web page all site users such as Coordinators, Investigators, Core Lab personnel and 
external Monitors use to access Oracle Clinical/Remote Data Capture (OC/RDC). 
 

 

Supported Computer Operating Systems 
Not all computers are supported by Oracle Clinical/Remote Data Capture (OC/RDC). 
 

Supported Browsers 

 Google Chrome 70 
o Microsoft Windows 10 
o Microsoft Windows 8 

 Microsoft Edge with IE (Internet Explorer) mode enabled 

 Safari 10 
o OS X 10.11 
o macOS 10.12 

 
Mobile Operating Systems 

 Safari 10 - iOS 10.3 
 
NOT Supported 
Internet Explorer 
Windows XP 
Android mobile devices 

https://onsite.medtronic.com/
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Supported Web Browsers – Google Chrome, Microsoft Edge, and Safari 
Google Chrome, Microsoft Edge, and Safari can be used to access Oracle Clinical/Remote Data 
Capture (OC/RDC). We cannot provide support or troubleshooting activities for any other web 
browser. Site users must work with their site IT group to upgrade to a supported browser. 
 
 
 
 
 
NOT Supported: Firefox will not work with Oracle Clinical/Remote Data Capture. 

 
 

Google Chrome General Settings 

Deleting Temporary Files 

 
1) Open Google Chrome 

2) Click on  the  icon in the toolbar and select Settings 

3) Click on Privacy and security 

4) Click on Clear browsing data 

5) Click on Advanced 

6) Set Time range selection to All time 

7) Click on Clear data 
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Site Settings – Cookies and sites data 

1) Open Google Chrome 

2) Click on  the  icon in the toolbar and select Settings 

3) Click on Privacy and security 

4) Click on Site Settings and scroll down to Content section and click on Cookies and site 

data 

5) Scroll to the section ‘Sites that can always use cookies’ and click the Add button. Enter 

the RDC URL https://onsite.medtronic.com and click Add.  

Site Settings – Images 

1) Open Google Chrome 

2) Click on  the  icon in the toolbar and select Settings 

3) Click on Privacy and security 

4) Click on Site Settings and scroll down to Content section and click on Images 

5) Click the Add button and enter the RDC URL https://onsite.medtronic.com and click Add. 

 

Site Settings – Pop-ups and redirects 

1) Open Google Chrome 

2) Click on  the  icon in the toolbar and select Settings 

3) Click on Privacy and security 

4) Click on Site Settings and scroll down to Content section and click on Pop-ups and 

redirects 

5) Click the Add button and enter the RDC URL https://onsite.medtronic.com and click Add. 

 

https://onsite.medtronic.com/
https://onsite.medtronic.com/
https://onsite.medtronic.com/
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Microsoft Edge with IE Mode 

 

Note: The IE mode has a default 30 day expiration period. The compatibility expiration value 
can be set from 0 to 90 days if managed by your local IT group. 

 

1. Open Microsoft Edge on Windows 10 

2. Click the Settings and More (ellipsis) button on the top-right corner  

3. Select the Settings option  

4. Click on Default browser  

5. Under the Internet Explorer compatibility section, turn on the Allow sites to be 
reloaded in Internet Explorer mode toggle switch. 

 

6. Click the Restart button to have Edge restarted. 

7. Once you are back in the Edge browser, return to the Default browser section (step 4). 

You can manually add the URL https://onsite.medtronic.com/rdcsso/login to the list of sites 
that need to be displayed in IE Mode. 

a. Click the Add button and paste the URL in the window that pops-up and click Add. 

 

 

Once the site is added, it will appear in the list with the expiration period of the IE 
mode: 

https://onsite.medtronic.com/rdcsso/login


   
 

12-Oct-2022 OC RDC 5.2 Site User Troubleshooting Guide Page 6 of 18 

 

b. Once a site is added to this list you can test the sites functionality/performance when 
it is in IE Mode. 

8. You will be able to confirm the site is in IE Mode by visiting the site and seeing an Internet 
Explorer icon to the left of the address bar. 

 

9. Your Edge browser is now configured to use OC/RDC. 

 

Microsoft Edge General Settings  
 

Deleting Temporary Files 
1) Open Edge 

2) Click on  the  icon in the toolbar and select Settings 

3) Click on Privacy, search, and services 

4) Scroll down to Clear browsing data, Click on Choose what to clear 

5) Set Time range selection to All time 

6) Make sure the first 4 options are selected 

7) Click on Clear now 
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8) From the same option Privacy, search, and services, scroll down to Clear browsing data 
for Internet Explorer  

9) Click on Choose what to clear 
10) Uncheck the boxes to Preserve Favorites website data and Passwords 
11) All the other items can be checked. 
12) Click Delete. 
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Cookies and site permissions – Cookies and data stored 
1) Open Edge 

2) Click on  the  icon in the toolbar and select Settings 

3) Click on Cookies and site permissions 

4) From Cookies and data stored, select Manage and delete cookies and site data 

5) From the section ‘Allow’ click the Add button. 

6) Enter the RDC URL https://onsite.medtronic.com and click Add.     

        

 

Cookies and site permissions – Images 

1) Open Edge 

2) Click on  the  icon in the toolbar and select Settings 

3) Click on Cookies and site permissions 

4) From Site Permissions, scroll down and click on Images 

5) From the section ‘Allow’ click the Add button. 

6) Enter the RDC URL https://onsite.medtronic.com and click Add.     

https://onsite.medtronic.com/
https://onsite.medtronic.com/
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Cookies and site permissions - Pop-ups and redirects 

The Pop-up Blocker should be turned off.  

1) Open Edge 

2) Click on  the  icon in the toolbar and select Settings 

3) Click on Cookies and site permissions 

4) From Site Permissions, scroll down and click on Pop-ups and redirects 

5) From the section ‘Allow’ click the Add button. 

6) Enter the RDC URL https://onsite.medtronic.com and click Add.     

 

  

https://onsite.medtronic.com/
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Safari 10 General Settings 
Safari Mobile 
The mobile browser version is the same as the iOS software version. 
 
1) Go to Settings > General > About > Software Version 
2) Go to Settings > Safari > Block Pop-ups and turn off the pop ups 
3) Go to Settings > Safari > Clear History and Website Data 
4) Go to Home > Open Safari browser and enter website https://onsite.medtronic.com and 

login. 
 
Mac Operating System (macOS) 
From the Apple menu in the corner of your screen, choose About This Mac. You will see the 
macOS name followed by its version number. 
 
1) Open Safari browser. From the top left corner click on Safari > Preferences 
2) Click Security & Privacy 
3) Place a check in the box beside Allow Java 
4) Place a check in the box beside Allow all other plug-ins 
5) Turn off the Pop-up blockers 
6) Go to Privacy. Look for the Cookies and website data heading and select Always allow 
7) Look for the Accept cookies heading and select Always 
 

Forgotten Password or Account Locked 
If a user has forgotten their password or their password expired (locked account) they will 
need to request a temporary password and then change their temporary password. An account 
will unlock when the password is changed. 

Requesting a Temporary Password 
Follow the steps below to request a temporary password. 
 
1) On the login page (https://onsite.medtronic.com) click on the Forgot Password/Unlock 

Account hyperlink. 

 

 

https://onsite.medtronic.com/
https://onsite.medtronic.com/
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2) Enter your user email address or Medtronic User Name then click NEXT. 

 

 

3) You will see a message that a new, temporary password has been sent to your e-mail 

address. The email is sent to the email address that your Medtronic study team entered in 

our system. 
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4) The user should look in their email inbox for the email. 

This is a sample of the email with a temporary password: 

 
 

If the email is not received: 

 The email is sent to the email address entered in the system. If the user has a new 
email address, they should contact their Medtronic study team. The study team can 
update the email in the system. Another way is to contact the Medtronic RDC Help 
Desk. The Help Desk cannot update the email address but will submit a support ticket. 

 The email may have been identified as ‘spam’ or ‘junk’ by the user’s email system. To 
correct this and ensure the email arrives, the site user should attempt to add 
helpdesk@medtronic.com as a trusted sender or add as a contact. 

 
5) After receiving the email, click the Return to login screen hyperlink to take you to the 

login page. 

 

mailto:helpdesk@medtronic.com
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6) On the login page https://onsite.medtronic.com enter your User Name and the temporary 

password received in the email and click Login. 

 

 

Changing your Temporary Password 
For security reasons, you will be asked to change your temporary password when you log in 
for the first time. 
 
A more secure password is one that is not easy to guess. Please follow the password 
requirements noted in your email with your temporary password. 
 
1) Enter the temporary password in the Old Password box and enter your new password in 

the New Password and Confirm New Password boxes. Click Change Password. 

https://onsite.medtronic.com/
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Confirm you receive a pop-up window displaying your new password has been set. Click on 
CONTINUE. 
 

 

 
2) You will be taken to the login page https://onsite.medtronic.com 

Enter your User Name and your new password and click Login. 

 

https://onsite.medtronic.com/
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3) If you have access to only one study, RDC will open automatically. If you have access to 

more than one study, you will be brought to your “Select a Study” page. You must select a 

study to proceed into RDC. If you decide to close your session you may click on Logout. 

 

 
 

 
 

Opening a New Session on a Mac 
If you receive a message “Multiple tabs are not supported for this application. Please close all 
browser windows and open a new browser session,” close all browser windows and then open 
a new session.  
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Go to File > New Private Window from the menu bar (Another way to do this is to click Shift-
Command-N using your keyboard shortcuts). 
 

 

Opening a New Session on iPad 
Tap [& hold] the Tab icon in the upper right-hand corner for options to display. Select New 
Private Tab to open a new RDC session. 
 

 

Opening a New Session on iPhone 
Tap [& hold] the Tab icon in the lower right -hand corner for options to display. Select New 
Private Tab to open a new RDC session. 
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How to Close CRFs (Case Report Form) 
All users should always close an open CRF using the correct method described below. If CRFs 
are not closed properly, the next time you open a CRF, you may encounter a CRF opening in 
browse mode. 
 
Correct Method Incorrect Method 
Click the red X in the CRF  Do not click the browser window X.  

   
 

How to Sign Out of RDC (onsite.medtronic.com) 
To minimize errors, please follow the below step to sign out of RDC. 
 
1) Click on the Logout link. 

 

Blank CRF Page 
There can be some issues if attempting to open a CRF using the Review tab. A common error 
is where the CRF does not open or only opens as a blank page. This does not occur all the 
time, but if it does, the workaround is to locate and open the CRFs using the Home tab. 
 

https://onsite.medtronic.com/
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Additional Help 
If further assistance is needed, please contact the RDC Help Desk. Go to 
https://onsite.medtronic.com. You can contact the Help Desk by Live Chat, telephone, or 
email. A troubleshooting help guide is also available on the login page. 
 

 

https://onsite.medtronic.com/

